Artefact dans une figure

Tout ce qui concerne le langage LaTeX et ses variantes. Ce langage est supporté sur le forum via les balises tex.

Modérateur : gdm_tex

Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
loicwood
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 121
Inscription : dimanche 23 octobre 2011, 11:24
Localisation : Souppes sur Loing

Artefact dans une figure

Message par loicwood »

Bonsoir,
j'utilise le code suivant :

Code : Tout sélectionner

\documentclass{book}
\usepackage[utf8]{inputenc}
\usepackage{pst-plot}
\begin{document}

\psset{unit=10}
\begin{pspicture}(0,-0.042)(1.1,0.45)
   \psaxes[comma,Dx=0.1,Dy=0.1,tickstyle=bottom,  
     xLabels={Janvier,Février,Mars,Avril,Mai,Juin,Juillet,Août,Septembre,Octobre,Novembre,Décembre},
     xLabelsRot=45,xmathLabel=false,xlabelFontSize=\footnotesize]{->}(0,0)(1.1,0.45)[Âge relatif,0][Taux d'évènements en \%,0]
\end{pspicture}

\end{document}
issu de http://tug.org/PSTricks/main.cgi?file=pst-plot/psaxes

J'obtiens près de l'origine du repère du texte parasite (1 0+1) que je n'arrive pas à enlever (ma figure est plus compliquée, mais le problème est le même).
Comment faire pour que cela n'arrive pas ?

Merci

balf
Utilisateur chevronné
Utilisateur chevronné
Messages : 3925
Inscription : mercredi 02 janvier 2008, 23:18

Re: artefact dans une figure

Message par balf »

Bonsoir,

Malheureusement, je n'obtiens pas du tout l'artefact décrit avec ce code (je compile avec xelatex). Pour vous il produit l'artefact ?
B. A.

gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2563
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: artefact dans une figure

Message par gigiair »

Aucun problème non plus avec une compilation latex+dvips+ps2pdf.
Sans l'option a4paper la page est au format Letter, peut-être certains lecteurs pdf n'apprécient pas. Je dis ça au hasard.
Voici l'ECM que j'ai adapté pour une compilation avec Emacs et avec la commande \listfiles pour vérifier la version des fichiers appelés par la compilation (TeXLive à jour).

Code : Tout sélectionner

\documentclass[a4paper]{book}
 \usepackage[utf8]{inputenc}
 \usepackage{pst-plot}
 \listfiles{}
 \begin{document}

 \psset{unit=10}
 \begin{pspicture}(0,-0.042)(1.1,0.45)
    \psaxes[comma,Dx=0.1,Dy=0.1,tickstyle=bottom,  
      xLabels={Janvier,Février,Mars,Avril,Mai,Juin,Juillet,Août,Septembre,Octobre,Novembre,Décembre},
      xLabelsRot=45,xmathLabel=false,xlabelFontSize=\footnotesize]{->}(0,0)(1.1,0.45)[Âge relatif,0][Taux d'évènements en \%,0]
 \end{pspicture}

 \end{document}
% Local Variables:
% TeX-PDF-mode: t
% TeX-PDF-via-dvips-ps2pdf: t
% End:
Le log se trouve en suivant ce lien : http://ix.io/1pUf

Le fichier pdf
tex-ecm-dd2F.pdf
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.
JJR.
LaTeXien migrateur.

loicwood
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 121
Inscription : dimanche 23 octobre 2011, 11:24
Localisation : Souppes sur Loing

Re: artefact dans une figure

Message par loicwood »

Voilà le fichier que j'obtiens (j'ai juste modifier utf8 en latin1) : https://www.dropbox.com/s/yy9eetebo7hdj ... t.pdf?dl=0

cela apparaît dans les fichiers dvi et ps également

gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2563
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: artefact dans une figure

Message par gigiair »

J'ai compilé en latin1 et j'ai toujours un rendu correct.
Vérifies dans le fichier log les versions des fichiers de \listfiles

Code : Tout sélectionner

*File List*
    book.cls    2014/09/29 v1.4h Standard LaTeX document class
    bk10.clo    2014/09/29 v1.4h Standard LaTeX file (size option)
inputenc.sty    2018/04/06 v1.3b Input encoding file
  latin1.def    2018/04/06 v1.3b Input encoding file
pst-plot.sty    2011/04/13 package wrapper for pst-plot.tex (hv)
pstricks.sty    2018/01/06 v0.67 LaTeX wrapper for `PSTricks' (RN,HV)
   iftex.sty    2013/04/04 v0.2 Provides if(tex) conditional for PDFTeX, XeTeX,
 and LuaTeX
shellesc.sty    2016/06/07 v0.02a unified shell escape interface for LaTeX
  xcolor.sty    2016/05/11 v2.12 LaTeX color extensions (UK)
   color.cfg    2016/01/02 v1.6 sample color configuration
   dvips.def    2017/06/20 v3.1d Graphics/color driver for dvips
pst-xkey.tex    2005/11/25 v1.6 PSTricks specialization of xkeyval (HA)
pst-xkey.tex    2005/11/25 v1.6 PSTricks specialization of xkeyval (HA)
 xkeyval.sty    2014/12/03 v2.7a package option processing (HA)
 xkeyval.tex    2014/12/03 v2.7a key=value parser (HA)
pstricks.tex    2018/08/23 v2.86 `PSTricks' (tvz,hv)
  pst-fp.tex    2018/08/23 v2.86 `PST-fp' (hv)
pst-xkey.sty    2005/11/25 v1.6 package wrapper for pst-xkey.tex (HA)
 multido.sty    2004/05/17 package wrapper for PSTricks `multido.tex', (HV/RN)
 multido.tex    2010/05/14 v1.42 `multido' (tvz,hv)
pst-plot.tex    2018/08/31 1.91 `pst-plot' (tvz,hv)
 ***********
Mon installation est très à jour (debian testing).
Autrement, je ne vois pas de raison pour laquelle le résultat n'est pas identique chez toi. Essaye de mettre à jour ton installation.

Si tu ne t'en sors pas, poste ici le log *complet*
JJR.
LaTeXien migrateur.

loicwood
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 121
Inscription : dimanche 23 octobre 2011, 11:24
Localisation : Souppes sur Loing

Re: artefact dans une figure

Message par loicwood »

merci ! la mise à jour a résolu le problème