Impossible d'installer le package chemfig

Tout ce qui concerne le langage LaTeX et ses variantes. Ce langage est supporté sur le forum via les balises tex.

Modérateur : gdm_tex

Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
pianiste06
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 118
Inscription : mardi 05 mai 2020, 08:29

Re: Impossible d'installer le package chemfig

Message par pianiste06 »

Merci balf,

J'ai tout bien installé, et je n'ai plus de message d'erreur !!! Il comprend maintenant la langue de Victor Hugo !!

Le dernier problème ... (pour le moment ...), c'est qu'il n'arrive pas à intégrer les chapitres appelés.
Pour cela, avant Begin document, j'ai inséré : \includeonly{Chap_1_AcideetBase} et après ... \includefrom{Chap1.AcideetBase/}{Chap_1_AcideetBase}.

Avant la nouvelle installation de Miktex (qui ne contenait pas Chemfig) tout marchait nickel.

Faut-il appeler les chapitres d'une autre manière avec la nouvelle version de Miktex ?
Toute suggestion, sera bienvenue...

jcs
Utilisateur chevronné
Utilisateur chevronné
Messages : 1358
Inscription : lundi 24 novembre 2008, 22:17

Re: Impossible d'installer le package chemfig

Message par jcs »

Bonjour,
Si vous avez effectué l'installation Miktex de base il y a plein de packages qui manquent.
Sur l'image de la page précédente il y a package. Ouvrez-le et vous verrez qu'il est aux trois quarts vide.
Pour les installer il faudra cliquer sur le + et il se charge de tout.

gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2563
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: Impossible d'installer le package chemfig

Message par gigiair »

1- Ta nouvelle question n'a plus rien à voir avec le sujet initial aurait mérité d'initier un nouveau fil, non ?
2- Tu aurais pu présenter un ECM comme le mien par exemple :

Code : Tout sélectionner

\documentclass[french]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{import}
\usepackage{babel}
\includeonly{Chap_1_AcideetBase}
\begin{document}
%>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Première page  ...
\includefrom{Chap1.AcideetBase/}{Chap_1_AcideetBase}
Troisième page
%<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
\end{document}
Ça éviterait aux éventuels testeurs de le faire eux même pour constater que le fichier censé être inclus ne l'est pas sans qu'il n'y ait de message d'erreur.

3- Si j'ajoute le chemin complet dans le \includeonly, il semble qu'il n'y ait pas de problème

Code : Tout sélectionner

\documentclass[french]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{import}
\usepackage{babel}
\includeonly{Chap1.AcideetBase/Chap_1_AcideetBase}
%%%%%%%%%%%%^^^^^^^^^^^^^^^^^^
\begin{document}
%>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Première page  ...
\includefrom{Chap1.AcideetBase/}{Chap_1_AcideetBase}
Troisième page
%<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
\end{document}
JJR.
LaTeXien migrateur.

pianiste06
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 118
Inscription : mardi 05 mai 2020, 08:29

Re: Impossible d'installer le package chemfig

Message par pianiste06 »

Bonjour,

J'ai suivi les instructions précédentes, et je me demande si je dois installer tous les packages ou sélectionner seulement certains d'entre eux.
Avant de faire une autre bourde, je préfère attendre votre réponse.
Merci très sincèrement pour votre précieuse aide.

gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2563
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: Impossible d'installer le package chemfig

Message par gigiair »

Quand il manque un package, il y a un message dans le log du genre

Code : Tout sélectionner

./TeX-ecmJg3qLe.tex:13: Undefined control sequence.
l.13 \toto
Ce qui veut dire que la commande \toto n'est pas connue. Comme il y a des milliers de commandes possibles, y compris celles qu'on peut définir soi-même, il faut chercher pour savoir quel package fournit la commande \toto.
Le web est pratique pour ça. Une fois que le package a été identifié, il suffit de l'installer, c'est le rôle du gestionnaire de packages de la distribution. A part se référer à ses statistiques de téléchargement, comment le gestionnaire de package pourrait-il deviner tes intentions et tes besoins autrement que par des probabilités ?
JJR.
LaTeXien migrateur.

pianiste06
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 118
Inscription : mardi 05 mai 2020, 08:29

Re: Impossible d'installer le package chemfig

Message par pianiste06 »

Merci pour la réponse. En effet, je comprends.

Voici le message que le compilateur me fournit :

Code : Tout sélectionner

("C:\Program Files\MiKTeX 2.9\tex/latex/sectsty\sectsty.sty"
Package: sectsty 2002/02/25 v2.0.2 Commands to change all sectional heading sty
les
LaTeX Warning: Command \underbar has changed.
Check if current package is valid.
LaTeX Warning: Command \underline has changed.
Dernière modification par MB le mercredi 13 mai 2020, 11:55, modifié 1 fois.
Raison : Balises Code.

pianiste06
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 118
Inscription : mardi 05 mai 2020, 08:29

Re: Impossible d'installer le package chemfig

Message par pianiste06 »

Dois-je comprendre par la que la version de Miktex que j'utilisais définissais \underline et \underbar de cette façon et sur la version de 2020, ces commandes sont obsolètes ?

gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2563
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: Impossible d'installer le package chemfig

Message par gigiair »

Ce n'est pas un message d'erreur (Error), c'est juste un avertissement (Warning) Il faut juste vérifier que l'effet des commandes \changebar et \underline qui ont changé de définition est bien celui qui est attendu.
Lorsqu'il y a une erreur, la compilation est en général interrompue et il n'y a aucun document pdf ou dvi produit.
JJR.
LaTeXien migrateur.

Arathorn
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 209
Inscription : mercredi 24 avril 2013, 19:47

Re: Impossible d'installer le package chemfig

Message par Arathorn »

Finalement, mon message avec les liens vers les sites était bon.
https://tex.stackexchange.com/questions ... as-changed
The warning is caused by a check sectsty runs on the definition of \underbar. If it doesn't match one of the definitions it expects, it warns you.

You can avoid this warning but I don't recommend it. The warning is telling you something important: that sectsty has found a definition of \underbar which is not what it expects and that things may not work properly.

In truth, I would recommend not using sectsty with LuaTeX/XeTeX. In particular, I wouldn't use it with unicode-math.

If you insist, for LuaTeX, you can avoid that particular warning by loading the package earlier. For XeTeX, you can avoid that warning by loading the package earlier.

pianiste06
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 118
Inscription : mardi 05 mai 2020, 08:29

Re: Impossible d'installer le package chemfig

Message par pianiste06 »

Je réalise en effet, que la discussion ne correspond plus au titre du sujet.
Je crée donc une nouvelle discussion par rapport à mon nouveau problème.