Les footfullcite n'apparaissent pas dans beamer

Tout ce qui concerne le langage LaTeX et ses variantes. Ce langage est supporté sur le forum via les balises tex.

Modérateur : gdm_tex

Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
XANA
Utilisateur confirmé
Utilisateur confirmé
Messages : 39
Inscription : lundi 04 septembre 2017, 17:56

[Résolu] Les footfullcite n'apparaissent pas dans beamer

Message par XANA »

Bonjour,

j'essaie d'insérer une biblio dans un diaporama avec LaTeX en utilisant footfullcite, mais celles-ci n’apprissent pas en bas. Il y a bien le 1 dans le texte, mais rien en bas de la page...
J'ai fait un ECM pour ce post, mais sur celui-ci cela fonctionne bien ! (mais ça ne marche pas sur mon grand fichier...)

Voici l'ECM :

Code : Tout sélectionner

\documentclass{beamer}
\usetheme{Madrid}

\setbeamertemplate{navigation symbols}{}
\usepackage[style=verbose,backend=biber]{biblatex}
\addbibresource{tst.bib}

\begin{document}
 \begin{frame}
    \frametitle{Frame}
    \setbeamerfont{footnote}{size=\tiny}
    Reference \footfullcite{reference}
    \end{frame}
\end{document}
avec le fichier tst.bib

Code : Tout sélectionner

@misc{reference,
	author = {Auteur},
    title = {Titre},
    year = {2020}
}
Et là c'est le gros fichier (j'ai enlevé plein de parties, j'ai juste laissé la partie conclusion, mais le problème reste encore), c'est peut être dû à un autre paquet que j'ai chargé qui empêche cela...

Code : Tout sélectionner

\documentclass[11pt,envcountsect,aspectratio=169]{beamer} %handout, draft
\usetheme{Madrid}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{pgf,tikz}
\usepackage[ruled]{algorithm2e}
\usepackage{multicol}
\usepackage{subfigure}
\usepackage{comment}
\usepackage{copyrightbox}
\usepackage{ifthen}
\usepackage{pgf}
\DeclareUnicodeCharacter{2212}{-}
\usepackage{setspace}

\usepackage{biblatex}
\usepackage{csquotes}
\addbibresource{tst.bib}

\author[Thomas]{%
    \texorpdfstring{
    Thomas\newline\newline
    {\small dirigé par ...}}{Thomas}}

\hypersetup{%
    bookmarksopen=false,
    pdfsubject={Project M1 CSMI},
}

\colorlet{punct}{red!60!black}
\definecolor{delim}{RGB}{20,105,176}
\definecolor{blbl}{RGB}{51,51,179}
\definecolor{comm}{RGB}{60,60,60}
\colorlet{numb}{magenta!60!black}

\usepackage{listings}
\lstdefinelanguage{json}{
    basicstyle=\normalfont\ttfamily\scriptsize,
    numbers=left,
    numberstyle=\tiny,
    stepnumber=1,
    numbersep=8pt,
    showstringspaces=false,
    breaklines=true,
    frame=lines,
    literate=
     *{0}{{{\color{numb}0}}}{1}
      {1}{{{\color{numb}1}}}{1}
      {2}{{{\color{numb}2}}}{1}
      {3}{{{\color{numb}3}}}{1}
      {4}{{{\color{numb}4}}}{1}
      {5}{{{\color{numb}5}}}{1}
      {6}{{{\color{numb}6}}}{1}
      {7}{{{\color{numb}7}}}{1}
      {8}{{{\color{numb}8}}}{1}
      {9}{{{\color{numb}9}}}{1}
      {:}{{{\color{punct}{:}}}}{1}
      {,}{{{\color{punct}{,}}}}{1}
      {\{}{{{\color{delim}{\{}}}}{1}
      {\}}{{{\color{delim}{\}}}}}{1}
      {[}{{{\color{delim}{[}}}}{1}
      {]}{{{\color{delim}{]}}}}{1},
    moredelim=[is][\color{comm}]{/-}{-/}
}
\lstdefinelanguage{cpp}{
    basicstyle=\normalfont\ttfamily\scriptsize,
    keywordstyle=\color{blue},
    numbers=left,
    numberstyle=\tiny,
    stepnumber=1,
    numbersep=8pt,
    showstringspaces=false,
    breaklines=true,
    frame=lines,
    morekeywords={*,for,if,auto,const,this,void},
    moredelim=[is][\color{comm}\itshape]{/-}{-/}
}

\newcommand{\sectitre}{\begin{frame}
    \begin{center}
    {\Large\bf \secname}
    \end{center}
    \end{frame}
}

\title{Modélisation hygrothermique et simulation}
\subtitle{\texorpdfstring{Soutenance du stage}{Stage}}
%\institute{} 
\date[26/08/2020]{26 août 2020}

% Macros
\newcommand{\R}{\mathbb{R}}
\newcommand{\Z}{\mathbb{Z}}
\newcommand{\C}{\mathbb{C}}
\newcommand{\ibat}{4fastsim-ibat}
\renewcommand{\d}{\,\mathsf{d}}
\renewcommand{\ss}{\vspace*{\baselineskip}}
\newcommand{\fpp}{Feel++}
% \renewcommand{\phi}{\varphi}
\def\sat{\mathsf{sat}}
\def\suc{\mathsf{suc}}
\def\eff{\mathsf{eff}}
\def\w{\mathsf{w}}
\def\p{\mathsf{p}}
\def\s{\mathsf{s}}
% \def\v{\mathsf{v}}
\newcommand{\n}{\mathbf{n}}
\newcommand{\incr}{\;+\hspace{-.4em}=}


\def\colora<#1>{\temporal<#1>{\color{black}}% noir avant
                               {\color{red!40!blue}}% rouge
                               {\color{black}}% noir après
}
\def\colorb<#1>{\temporal<#1>{\color{black}}% noir avant
                               {\color{blue}}% bleu
                               {\color{black}}% noir après
}
\def\colorc<#1>{\temporal<#1>{\color{black}}% noir avant
                               {\color{green!60!black}}% bleu
                               {\color{black}}% noir après
}


% \usepackage{pgf,tikz}
% \usetikzlibrary{positioning,shapes,shadows,arrows}

\definecolor{ttttff}{rgb}{0.2,0.2,1}
\definecolor{xdxdff}{rgb}{0.49,0.49,1}


\newcommand\thm[2]{%
    \begin{beamerboxesrounded}[upper=titreB,lower=texteB,shadow=true]{Theorem : #1}
        \it #2
    \end{beamerboxesrounded}
    \normalfont
}

\newcommand\defi[2]{%
    \begin{beamerboxesrounded}[upper=titreB,lower=texteB,shadow=true]{Definition : #1}
        \it #2
    \end{beamerboxesrounded}
    \normalfont
}

\begin{document}

\begin{frame}[plain]
\titlepage
\end{frame}

% Table of content
\begin{frame}{Table des matières}
\small
\begin{spacing}{0.2}
\tableofcontents[hideallsubsections]
\end{spacing}
\normalsize
\end{frame}

\section{Conclusion}
\begin{frame}{}
    \setbeamerfont{footnote}{size=\tiny}
    Le rapport du stage\footfullcite{reference}
\end{frame}

\end{document}
Merci

XANA
Utilisateur confirmé
Utilisateur confirmé
Messages : 39
Inscription : lundi 04 septembre 2017, 17:56

Re: Les footfullcite n'apparaissent pas dans beamer

Message par XANA »

Après recherche, la ligne qui posait problème était \usepackage{setspace} : si je l'enlève du préambule, tout vas très bien...
Je ne vois pas ce qui a causé cela... Mais maintenant ça va bien !

MB
Administrateur
Administrateur
Messages : 7189
Inscription : samedi 28 mai 2005, 14:23
Statut actuel : Enseignant

Re: Les footfullcite n'apparaissent pas dans beamer

Message par MB »

Merci pour le retour. Je peux marqué le sujet comme résolu ?
MB (Pas d'aide en Message Privé)
Merci d'utiliser MathJax (voir ici) et d'éviter le style SMS pour la lisibilité des messages.

XANA
Utilisateur confirmé
Utilisateur confirmé
Messages : 39
Inscription : lundi 04 septembre 2017, 17:56

Re: Les footfullcite n'apparaissent pas dans beamer

Message par XANA »

MB a écrit :
jeudi 20 août 2020, 20:53
Merci pour le retour. Je peux marqué le sujet comme résolu ?
Oui, merci