Opacité avec pscustom et psplot

Tout ce qui concerne le langage LaTeX et ses variantes. Ce langage est supporté par le forum via les balises tex.

Modérateur : gdm_tex

Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
marco56
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 918
Inscription : jeudi 25 novembre 2010, 22:10

[Résolu] Opacité avec pscustom et psplot

Message par marco56 »

Bonsoir,
Je voudrais opacifier le coin de ma zone en haut à droite formé par une courbe (psplot) et 2 lignes (psline).
J'ai regardé quelques exemples et j'ai su faire mais je bloque.
Plutôt que de tourner en rond pendant 2 heures, je préfère poser ma question ici. :)
Voici mon code (avec le pscustom qui ne fonctionne pas) :

Code : Tout sélectionner

\documentclass{article}
\usepackage{pst-all}

\begin{document}

\psset{xunit=4cm}
\begin{pspicture}(-0.25,-.5)(2.5,6.4)
\psgrid[subgriddiv=5, gridlabels=0, gridcolor=gray, subgridcolor=orange!40](0,0)(2,5)
\psplot[algebraic=True,linecolor=violet]{0.6}{2}{3/x}
\pscustom[fillstyle=solid,fillcolor=yellow,linestyle=none,opacity=.4]{%
\psplot{0.6}{2}{3/x}
\psline(0.6,5)(2,5)
\psline(2,5)(2,1.5)
}
\end{pspicture}

\end{document}
Bon week-end froid.
Dernière modification par marco56 le samedi 13 février 2021, 12:18, modifié 1 fois.
jcs
Utilisateur chevronné
Utilisateur chevronné
Messages : 1368
Inscription : lundi 24 novembre 2008, 22:17

Re: pscustom et psplot

Message par jcs »

Bonsoir

Ce qui ne fonctionne pas c'est plutôt l'écriture algébrique.
En écrivant \psplot{0.6}{2}{3 x div} j'ai bien une partie colorée en jaune.
kojak
Modérateur général
Modérateur général
Messages : 10396
Inscription : samedi 18 novembre 2006, 19:50

Re: pscustom et psplot

Message par kojak »

Bonjour

Il faut peut être préciser l'option algebraic=true dans psplot ou simplement algebraic. ;)
Pas d'aide par MP.
marco56
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 918
Inscription : jeudi 25 novembre 2010, 22:10

Re: Opacité avec pscustom et psplot

Message par marco56 »

Merci, effectivement, en mettant en RPN, cela fonctionne.
J'ai eu des résultats intermédiaires étranges mais c'est ok maintenant.
Bon week-end.