Caractères bizarres avec Texmaker

Tout ce qui concerne le langage TeX/LaTeX et ses variantes. Ce langage est utilisable sur le forum via les balises tex.
[participation réservée aux membres inscrits]
Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
claire
Utilisateur confirmé
Utilisateur confirmé
Messages : 22
Inscription : jeudi 25 septembre 2008, 18:51

Caractères bizarres avec Texmaker

Message non lu par claire »

Bonjour,

j'ai changé depuis quelques mois pour Texmaker (après avoir utilisé winshell) et si j'apprécie cet éditeur, des caractères bizarres viennent ralentir la frappe.

De temps à autre mais suffisamment régulièrement pour que j'en sois gênée, sans que j'ai pu trouver un lien logique, un caractère ( • ○ ♠ entre autres ...). vient se rajouter dans les lignes entre balises. Évidemment, cela provoque des erreurs de compilation qd je ne les repère pas à temps.

Quelqu'un pourrait-il m'expliquer éviter qu'ils apparaissent ? J'ai l'impression que cela ne se passe pas de la même façon sur les ordis du lycée où je viens de le faire installer sur 2 postes (je n'ai toutefois pas encore eu le temps de beaucoup les utiliser).

Il n'y a pas d'urgence mais j'avoue que je commence à m'agacer.

Merci de bien vouloir partager vos solutions.
touhami
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 447
Inscription : dimanche 11 février 2007, 11:45

Re: caractères bizarres avec Texmaker

Message non lu par touhami »

Bonjour. Moi aussi j'ai ce problème, peut-être bug, avec les anciennes versions je n'avais pas ça.
rebouxo
Modérateur honoraire
Modérateur honoraire
Messages : 6962
Inscription : mercredi 15 février 2006, 13:18
Localisation : le havre

Re: Caractères bizarres avec Texmaker

Message non lu par rebouxo »

Problème d'encodage. Cela se passe sur les caractères accentués ?

Olivier
A line is a point that went for a walk. Paul Klee.
Par solidarité, pas de MP.
claire
Utilisateur confirmé
Utilisateur confirmé
Messages : 22
Inscription : jeudi 25 septembre 2008, 18:51

Re: Caractères bizarres avec Texmaker

Message non lu par claire »

Non, pas du tout. Les caractères accentués sont parfaitement écrits.
Ce sont bien des caractères qui s'ajoutent au code : on veut taper \newpage et il s'écrit par exemple \♥newpage.
Du coup, si on n'enlève pas le caractère ajouté, évidemment, cela ne compile pas.
Je voudrais donc savoir ce que je dois modifier dans mon TexMaker pour ne pas avoir ces ajouts.

merci
gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2642
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: Caractères bizarres avec Texmaker

Message non lu par gigiair »

Il s'agit visiblement d'un bug. Tu peux essayer de recompiler texmaker, si tu as les sources et un environnement de compilation, et si tu sais faire, en corrigeant le bug.
Autrement, il faut attendre. S'il existe une liste de diffusion pour texmaker, tu peux signaler le problème. L'auteur Pascal Brachet passait souvent par ici, peut-être est-il en train de corriger le bug. Autrement TeXStudio est paraît-il très semblable (et même supérieur mais ça le fâche de dire ça).
JJR.
LaTeXien migrateur.
kojak
Modérateur général
Modérateur général
Messages : 10407
Inscription : samedi 18 novembre 2006, 19:50

Re: Caractères bizarres avec Texmaker

Message non lu par kojak »

Bonjour,

Il est tout à fait possible de contacter l'auteur de Texmaker par mail, vu qu'il se trouve sur son site. Mais bien lui préciser la version utilisée, l'OS, etc. de façon à faire avancer le scmilblick.
Pas d'aide par MP.
claire
Utilisateur confirmé
Utilisateur confirmé
Messages : 22
Inscription : jeudi 25 septembre 2008, 18:51

Re: Caractères bizarres avec Texmaker

Message non lu par claire »

Merci de vos conseils. Je vais en effet essayer de contacter l'auteur sur son site. Je posterai la solution donnée pour clore la discussion.
texmaker
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 226
Inscription : vendredi 30 juillet 2010, 12:19

Re: Caractères bizarres avec Texmaker

Message non lu par texmaker »

1) Il y a un lien contact sur chaque page du site de Texmaker (difficile à rater!!).
2) Il y a aussi un lien vers le tracker sur chaque page du site.
3) Impossible de reproduire le problème que ce soit sous windows (ce qui doit être l'os utilisé vu que winshell n'existe que sous windows - testé sous seven ou 8 ), macosx ou linux.
4) Depuis 1 mois et demi qu'est sorti la dernière version personne d'autre n'a jamais signalé ce problème que ce soit via le tracker ou par mail.
5) Rien n'a changé concernant l'entrée/sortie de l'éditeur depuis la dernière version.

Pistes probables :
- document corrompu ou enregistré/ouvert sous des encodages différents.
- le fichier de config de Texmaker a été bidouillé et/ou corrompu.
Suggère de réinitialiser la config : Option -> Fichier de configuration -> Réinitialiser la config (voir de désinstaller Texmaker, de le re-télécharger et de le réinstaller) et de tester avec un document vierge.
Texmaker (version courante : 5.0.4) : éditeur LaTeX libre et multi-plateforme avec afficheur pdf.
PdfAdd : Tableaux variations, courbes, arbres, graphes, loi binomiale, cercle trigo, suites pour pdflatex et Asymptote
Site de documentation sur LaTeX
raphkebab
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 227
Inscription : mardi 31 décembre 2013, 12:37
Localisation : Caen

Re: Caractères bizarres avec Texmaker

Message non lu par raphkebab »

J'ai le même souci sous Textudio quand je suis sous windows. Il ne me s'emble pas avoir eu ce problème sous linux.
guiguiche
Modérateur général
Modérateur général
Messages : 8125
Inscription : vendredi 06 janvier 2006, 15:32
Statut actuel : Enseignant
Localisation : Le Mans

Re: Caractères bizarres avec Texmaker

Message non lu par guiguiche »

Je sens venir un problème sous windows (seven en ce qui me concerne) car j'ai aussi parfois l'apparition aléatoire de tels symboles sous LyX après un backslash depuis environ un mois.
Pas d'aide par MP : les questions sont publiques, les réponses aussi.
Tu as apprécié l'aide qui t'a été fournie ? Alors n'hésite pas à rendre la pareille à quelqu'un d'autre.
Un peu d'autopromotion.
Euher
Utilisateur confirmé
Utilisateur confirmé
Messages : 22
Inscription : samedi 11 avril 2015, 08:30
Statut actuel : Enseignant

Re: Caractères bizarres avec Texmaker

Message non lu par Euher »

Bonjour à tous,
Nouveau sur ce forum (que je consulte régulièrement depuis trois ans...), je me permets de remonter ce post sur les caractères qui apparaissent aléatoirement après un backslash avec Texmaker.
Depuis la dernière mise à jour (4.4.1), j'ai moi aussi ce problème. Quelqu'un a-t-il trouvé une solution ?
Merci d'avance.
touhami
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 447
Inscription : dimanche 11 février 2007, 11:45

Re: Caractères bizarres avec Texmaker

Message non lu par touhami »

Je pense que ce n'est pas un problème de Texmaker. Il s'agit peut être à un problème du système ou de clavier (je ne sais pas). j'ai rencontré ça sur d'autres applications et même dans la zone d'édition des forums. Je pense que le problème et en relation avec
Alt Gr.
Pour votre question: je n'ai pas chercher une solution.
Euher
Utilisateur confirmé
Utilisateur confirmé
Messages : 22
Inscription : samedi 11 avril 2015, 08:30
Statut actuel : Enseignant

Re: Caractères bizarres avec Texmaker

Message non lu par Euher »

J'ai des doutes : chez moi le problème ne se pose qu'avec Texmaker,
et il est apparu précisément le jour où j'ai installé la version 4.4.1
Merci pour les retours.
romm

Re: Caractères bizarres avec Texmaker

Message non lu par romm »

Bonjour,

Ce post date un peu mais j'ai également ce problème. Personne n'en a trouvé de solution ?
J'utilise Windows 7, tekmaker 4.5 et un clavier Logitech K120.
balf
Modérateur spécialisé
Modérateur spécialisé
Messages : 4045
Inscription : mercredi 02 janvier 2008, 23:18

Re: Caractères bizarres avec Texmaker

Message non lu par balf »

Je ne me sers pas habituellement de TeXmaker, mais je l'ai sur mon système (Windows 7) pour tester le cas échéant. Je n'ai pas constaté cet étrange phénomène. Pourriez-vous poster un exemple de code qui pose ce problème en expliquant ce que vous avez voulu tapé (p. ex. avec un autre éditeur) et ce que vous obtenez.

B. A.
guiguiche
Modérateur général
Modérateur général
Messages : 8125
Inscription : vendredi 06 janvier 2006, 15:32
Statut actuel : Enseignant
Localisation : Le Mans

Re: Caractères bizarres avec Texmaker

Message non lu par guiguiche »

Le problème persiste chez moi sous LyX (j'utilise très rarement TeXmaker mais je me demande s'il n'est pas apparu lorsque j'ai installé TeXmaker), win10, langue FRA clavier MAEL.
Je pense qu'il y a un conflit WIN qui apparait lors de l'installation de TeXmaker (lié à l'extension linguistique MAEL ???)
Pas d'aide par MP : les questions sont publiques, les réponses aussi.
Tu as apprécié l'aide qui t'a été fournie ? Alors n'hésite pas à rendre la pareille à quelqu'un d'autre.
Un peu d'autopromotion.
jrivet

Re: Caractères bizarres avec Texmaker

Message non lu par jrivet »

Bonjour
Je tombe sur cet ancien post et ça m'intéresse. J'ai rencontré ce problème avec Texstudio et Texworks à la maison comme sur les ordis du lycée. Je pense aussi que le problème vient de l'OS car j'ai testé avec plusieurs claviers différents. Toujours pas de solution!
guiguiche
Modérateur général
Modérateur général
Messages : 8125
Inscription : vendredi 06 janvier 2006, 15:32
Statut actuel : Enseignant
Localisation : Le Mans

Re: Caractères bizarres avec Texmaker

Message non lu par guiguiche »

Extension Maël ou pas ?
Pas d'aide par MP : les questions sont publiques, les réponses aussi.
Tu as apprécié l'aide qui t'a été fournie ? Alors n'hésite pas à rendre la pareille à quelqu'un d'autre.
Un peu d'autopromotion.
evariste_G
Utilisateur chevronné
Utilisateur chevronné
Messages : 1472
Inscription : vendredi 19 décembre 2008, 19:13
Statut actuel : Enseignant
Localisation : Bordeaux

Re: Caractères bizarres avec Texmaker

Message non lu par evariste_G »

J'ai aussi remarqué ce phénomène sous Pyzo (écrit avec QT aussi... est-ce lié ?).
Chez moi, il ne me semble pas que le clavier maël soit installé (à vrai dire, j'ai du mal à comprendre ce que c'est : j'ai effectué des recherches succinctes à a priori, il faudrait installer quelque chose). Dans les paramètres de Windows 10, rien n'apparaît chez moi avec maël (les majuscules accentuées sont désactivées).

Je serais donc tenté de dire qu'il y a un lien avec QT5... Mais il faudrait testé d'autres logiciels sous QT5 pour voir.
Je précise, pour que ce soit clair pour tout le monde que ces symboles apparaissent quand on tape un antislash "\" suivi d'une lettre, mais c'est assez rare (j'ai voulu essayer de mettre un exemple ici, j'ai donc ouvert TeXmaker, mais rien n'est apparu... Effet Bonaldi !)
Mathématiques, LaTeX et Python : https://www.mathweb.fr
Cours particuliers de maths par webcam: https://courspasquet.fr
guiguiche
Modérateur général
Modérateur général
Messages : 8125
Inscription : vendredi 06 janvier 2006, 15:32
Statut actuel : Enseignant
Localisation : Le Mans

Re: Caractères bizarres avec Texmaker

Message non lu par guiguiche »

Ça par exemple : \♦sum ?
Pas d'aide par MP : les questions sont publiques, les réponses aussi.
Tu as apprécié l'aide qui t'a été fournie ? Alors n'hésite pas à rendre la pareille à quelqu'un d'autre.
Un peu d'autopromotion.