[Obsolète][Wiki] Pages concernant LaTeX

Tout ce qui concerne le langage LaTeX et ses variantes. Ce langage est supporté sur le forum via les balises tex.

Modérateur : gdm_tex

Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
MB
Administrateur
Administrateur
Messages : 7132
Inscription : samedi 28 mai 2005, 14:23
Statut actuel : Enseignant

[Obsolète][Wiki] Pages concernant LaTeX

Message par MB »

Une section du wiki mathematex est dédié à LaTeX : ça se passe ici. Les membres du forum peuvent participer à l'enrichissement de ce wiki : ce sujet est fait pour discuter d'éventuelles nouvelles idées ainsi que pour signaler les nouveautés.

J'en profite pour annoncer qu'après la page Installation de MiKTeX sous Windows, je viens d'ajouter la page Installation de TeX Live sous Linux. Pour l'instant, cette page donne quelques indications concernant l'utilisation de tlmgr pour l'installation d'un paquet. Elle sera certainement amenée à évoluer.

Cordialement,
MB.
MB (Pas d'aide en Message Privé)
Merci d'utiliser MathJax (voir ici) et d'éviter le style SMS pour la lisibilité des messages.

Francky
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 681
Inscription : dimanche 11 avril 2010, 14:01

Re: [Wiki] Pages concernant LaTeX

Message par Francky »

Merci, mais je me demande bien où tu as pris ces exemples ? :wink:
-
Il serait intéressant d'ajouter (où ?) que si l'on souhaite installer asymptote_svn, il vaut mieux ne pas l'installer celle de TeXLive.
Mais là encore, je ne sais pas d'où cet exemple pourrait venir ?
Linux Mint | TeXLive - TexMaker - asymptote | Python3 & C - Geany - Project Euler - SPOJ
Entia non sunt multiplicanda praeter necessitatem

MB
Administrateur
Administrateur
Messages : 7132
Inscription : samedi 28 mai 2005, 14:23
Statut actuel : Enseignant

Re: [Wiki] Pages concernant LaTeX

Message par MB »

Francky a écrit :Merci, mais je me demande bien où tu as pris ces exemples ? :wink:
Oui, ça faisait un moment que je voulais le faire, tu m'en as donné l'occasion. :)
Francky a écrit :Il serait intéressant d'ajouter (où ?) que si l'on souhaite installer asymptote_svn, il vaut mieux ne pas l'installer celle de TeXLive.
Je pense qu'il serait préférable d'indiquer ça sur la page concernant l'installation d'asymptote_svn. Ces histoires de conflits peuvent en effet concerner pas mal de monde. Je te laisse faire si tu veux. :)
MB (Pas d'aide en Message Privé)
Merci d'utiliser MathJax (voir ici) et d'éviter le style SMS pour la lisibilité des messages.

Francky
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 681
Inscription : dimanche 11 avril 2010, 14:01

Re: [Wiki] Pages concernant LaTeX

Message par Francky »

MB a écrit :Je te laisse faire si tu veux. :)
J'en suis incapable, il y a des cas trop complexes pour moi.

Ce que je mettrais, au début :
A] Si vous avez texlive et texmaker par les dépôts, alors ... bon courage, sauf*
EDIT : voir plus bas

B] Si vous avez texlive par les dépôts et pas texmaker.
Désinstaller une éventuelle version d'asymptote des dépôts et suivez les consignes ... ça roule. N'installez pas texmaker, sauf*
EDIT : voir plus bas

C] Si vous avez texlive vanilla (?) alors veillez à ne pas avoir installer asymtote dans la collection-binextra: TeX auxiliary programs. Il ne faut donc pas faire une full-install. Ensuite, suivez le guide ...
N'installez pas texmaker par les dépôts dans tous les cas ! Sauf*

--------

* Autre piste : il doit bien y avoir un moyen d'avoir deux version d'asymptotes (facile, en installant texmaker des dépôts),
mais d'avoir que celle qu'on veut d'active. (plus dur !! Comment fait-on ?). Ce serait même une bonne solution de secours en cas de bug, de pouvoir tester asy2.09 puis 2.02 (par exemple).

Je ne sais pas faire. Cela peut être intéressant.

EDIT : Il est possible d'installer ensuite texmaker en installant le paquet sur le site de l'auteur, pour lui toutes les dépendances sont satisfaites, vous avez donc la dernière version de texmaker.
Linux Mint | TeXLive - TexMaker - asymptote | Python3 & C - Geany - Project Euler - SPOJ
Entia non sunt multiplicanda praeter necessitatem

MB
Administrateur
Administrateur
Messages : 7132
Inscription : samedi 28 mai 2005, 14:23
Statut actuel : Enseignant

Re: [Wiki] Pages concernant LaTeX

Message par MB »

J'ai ajouté une partie "Problèmes de conflits possibles" : pas le temps de la remplir actuellement mais on verra ça.
Francky a écrit :* Autre piste : il doit bien y avoir un moyen d'avoir deux version d'asymptotes (facile, en installant texmaker des dépôts), mais d'avoir que celle qu'on veut d'active. (plus dur !! Comment fait-on ?). Ce serait même une bonne solution de secours en cas de bug, de pouvoir tester asy2.09 puis 2.02 (par exemple).
Oui, ça serait en effet une solution très satisfaisante et peut être la meilleur. Je pense qu'il peut suffire de modifier quelques liens symboliques. A étudier ...
MB (Pas d'aide en Message Privé)
Merci d'utiliser MathJax (voir ici) et d'éviter le style SMS pour la lisibilité des messages.

MB
Administrateur
Administrateur
Messages : 7132
Inscription : samedi 28 mai 2005, 14:23
Statut actuel : Enseignant

Re: [Wiki] Pages concernant LaTeX

Message par MB »

Le fichier /usr/local/bin/asy est celui installé lors de l'installation d'asymptote via svn (il ne s'agit pas d'un lien symbolique). Par contre, lors de l'installation d'asymptote par texlive, ce même fichier doit être un lien symbolique vers /usr/local/texlive/2009/bin/i386-linux/asy (pour une version 2009 de texlive). Pour pouvoir utiliser les deux versions, le plus simple est sans doute de créer un lien symbolique asy-tl dans /usr/local/bin/ qui pointerait vers le binaire texlive.

Code : Tout sélectionner

$ cd /usr/local/bin
# ln -s /usr/local/texlive/2009/bin/i386-linux/asy asy-tl
Ceci est à adapter en fonction de la version de texlive. Pour obtenir, l'emplacement de tous les fichiers asy, on peut utiliser la commande suivante :

Code : Tout sélectionner

$ locate -b '\asy'
MB (Pas d'aide en Message Privé)
Merci d'utiliser MathJax (voir ici) et d'éviter le style SMS pour la lisibilité des messages.

Aleph
Utilisateur confirmé
Utilisateur confirmé
Messages : 86
Inscription : mardi 05 janvier 2010, 16:38

Re: [Wiki] Pages concernant LaTeX

Message par Aleph »

Bonjour,

dans la section concernant le module animate, le document pdf censé être animé ne l'est pas chez moi et je dispose d'acrobat reader 9.

EDIT : je viens de comprendre... ;-) RAS tout est normal! Google Chrome ouvre les pdf sans passer par acrobat. En téléchargeant le fichier puis en l'ouvrant avec acrobat l'animation est visible.

Tonn83
Utilisateur éprouvé
Utilisateur éprouvé
Messages : 886
Inscription : mercredi 05 novembre 2008, 01:19
Localisation : Paris, France

Re: [Wiki] Pages concernant LaTeX

Message par Tonn83 »

----------------------------
Tonn83

MB
Administrateur
Administrateur
Messages : 7132
Inscription : samedi 28 mai 2005, 14:23
Statut actuel : Enseignant

Re: [Wiki] Pages concernant LaTeX

Message par MB »

A l'occasion de la sortie de la version 2014, j'ai modifié la page du wiki concernant cette distribution ainsi que son installation sous linux. Je propose également un script qui peut s'avérer utile pour automatiser cette installation. Les commentaires sont les bienvenus. Ca se passe ici.
MB (Pas d'aide en Message Privé)
Merci d'utiliser MathJax (voir ici) et d'éviter le style SMS pour la lisibilité des messages.