[tkz-fct] La courbe ne s'affiche pas !

Tout ce qui concerne le langage TeX/LaTeX et ses variantes. Ce langage est utilisable sur le forum via les balises tex.
[participation réservée aux membres inscrits]
Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
Leïla
Utilisateur confirmé
Utilisateur confirmé
Messages : 15
Inscription : vendredi 21 mai 2021, 12:32
Statut actuel : Étudiant

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par Leïla »

J'ai installe gnuplot comme suit :
Destination location:
C:\Program Files\gnuplot

Setup type:
Full installation

Selected components:
gnuplot Core Components
gnuplot Documentation
gnuplot Demos
Third Party License Information

Start Menu folder:
gnuplot

Additional tasks:
Select gnuplot's default terminal:
Don't change my GNUTERM environment variable
Other tasks:
Set file associations:
Associate gnuplot with the .plt file extension
Associate gnuplot with the .gp file extension
Associate gnuplot with the .gpl file extension
Add application directory to your PATH environment variable
Ensuite j'ai recherché
dir C:\gnuplot.exe /s
et ai copié-collé le chemin d'accès que ça m'a donné (
C:\Program Files\gnuplot\bin
) au début de la liste des variables d'environnement utilisateur du PATH.
J'ai ensuite regardé ce que ça donnait sur LaTeX : toujours la grille et les axes sans la courbe... :?
cpierquet
Utilisateur débutant
Utilisateur débutant
Messages : 2
Inscription : dimanche 29 novembre 2020, 21:29
Statut actuel : Enseignant

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par cpierquet »

Cela semble effectivement lié à l'option --enable-write18 (ou --shell-escape), je viens de tester (sur texstudio) et sans le shell-espace pas de courbe, avec le shell-escape courbe ok... Peut-être les 2 traits au début de l'option --shell-escape ?

Si c'est jouable, il faudrait tester en ligne de commandes directement :
  • lancer le fenêtre de commandes (cmd) et naviguer dans le répertoire où si situe le fichier tex à compiler
  • lancer la commande

    Code : Tout sélectionner

    pdflatex.exe --shell-escape -synctex=1 -interaction=nonstopmode <nomfichier>.tex
Peut-être que l'erreur sera plus explicite en ligne de commandes ?


Edit : je viens d'essayer avec texworks et au début cela ne marchait pas, j'avais mis l'option shell-escape après $fullname, en le "montant" avant cela marche !
2021-05-24_21-28-39.png
Leïla
Utilisateur confirmé
Utilisateur confirmé
Messages : 15
Inscription : vendredi 21 mai 2021, 12:32
Statut actuel : Étudiant

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par Leïla »

Merci, ça fonctionne ! Hourra !
Leïla
Utilisateur confirmé
Utilisateur confirmé
Messages : 15
Inscription : vendredi 21 mai 2021, 12:32
Statut actuel : Étudiant

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par Leïla »

Comment on fait pour passer en résolu ?
Leïla
Utilisateur confirmé
Utilisateur confirmé
Messages : 15
Inscription : vendredi 21 mai 2021, 12:32
Statut actuel : Étudiant

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par Leïla »

Au fait je précise pour d'éventuels visiteurs ultérieurs : mon objectif premier était de faire un document beamer (quand j'arrive pas à faire ce que je veux je créée un document "brouillon" à côté pour bidouiller tranquille).
Quand j'ai copié-collé le code de la figure dans mon document original, je me suis retrouvée avec le même problème.
Au final, il faut le compiler deux fois : la première en pdfLaTeX (après avoir fait les manips décrites au-dessus bien sûr), on obtient bien notre fonction tout comme il faut ; la deuxième en pdfLaTeX+MakeIndex+BibTeX, on a toujours notre courbe mais cette fois dans un beau document beamer (en pdfLaTeX il manque des trucs, le sommaire notamment)
MB
Administrateur
Administrateur
Messages : 7512
Inscription : samedi 28 mai 2005, 14:23
Statut actuel : Enseignant

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par MB »

Leïla a écrit : mardi 25 mai 2021, 08:10 Comment on fait pour passer en résolu ?
Je viens de le faire. Il suffit d'éditer le premier message et de sélectionner l'icône de sujet qui convient.
MB. (rejoignez pCloud afin d'obtenir 10Go de stockage en ligne gratuits)
Pas d'aide en message privé. Merci de consulter ce sujet avant de poster votre premier message.
Leïla
Utilisateur confirmé
Utilisateur confirmé
Messages : 15
Inscription : vendredi 21 mai 2021, 12:32
Statut actuel : Étudiant

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par Leïla »

Ok merci !
gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2642
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par gigiair »

MB a écrit : mardi 25 mai 2021, 08:56
Leïla a écrit : mardi 25 mai 2021, 08:10 Comment on fait pour passer en résolu ?
Je viens de le faire. Il suffit d'éditer le premier message et de sélectionner l'icône de sujet qui convient.
Non, non, ça n'a pas été fait !
JJR.
LaTeXien migrateur.
MB
Administrateur
Administrateur
Messages : 7512
Inscription : samedi 28 mai 2005, 14:23
Statut actuel : Enseignant

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par MB »

Pourquoi ça ? Il y a bien l'icône résolu (Image) sur le sujet il me semble ?
MB. (rejoignez pCloud afin d'obtenir 10Go de stockage en ligne gratuits)
Pas d'aide en message privé. Merci de consulter ce sujet avant de poster votre premier message.
gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2642
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: [tkz-fct] La courbe ne s'affiche pas !

Message non lu par gigiair »

Au temps pour moi. Autrefois on écrivait [résolu] au début du sujet, c'était plus clair...
JJR.
LaTeXien migrateur.