Barre verticale manquante sur mes tableaux

Tout ce qui concerne le langage TeX/LaTeX et ses variantes. Ce langage est utilisable sur le forum via les balises tex.
[participation réservée aux membres inscrits]
Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
rgbnkk49
Utilisateur débutant
Utilisateur débutant
Messages : 1
Inscription : mercredi 30 mars 2022, 15:56
Statut actuel : Étudiant

Barre verticale manquante sur mes tableaux

Message non lu par rgbnkk49 »

Bonjour,

Je viens vers vous aujourd'hui puisque j'ai un soucis sur Latex (Texshop). Les barres verticales de mes tableaux n'apparaissent pas. Je n'ai aucun message d'erreur mais rien ne se passe.

Merci d'avance.

Code : Tout sélectionner

\begin{table}[htp]
\caption{default}
\begin{center}
\begin{tabular}{|c|c|}
\hline
ok & ok  \\
\hline
\end{tabular}
\end{center}
\label{default}
\end{table}%
Pièces jointes
Capture d’écran 2022-03-30 à 16.01.53.png
Capture d’écran 2022-03-30 à 16.01.53.png (5.92 Kio) Consulté 183 fois
Dernière modification par MB le mercredi 30 mars 2022, 16:17, modifié 1 fois.
Raison : Remise en forme du message.
marco56
Utilisateur chevronné
Utilisateur chevronné
Messages : 1083
Inscription : jeudi 25 novembre 2010, 22:10

Re: Barre verticale manquante sur mes tableaux

Message non lu par marco56 »

Aucun souci :

Code : Tout sélectionner

\documentclass{article}

\begin{document}
\begin{table}[htp]
\caption{default}
\begin{center}
\begin{tabular}{|c|c|}
\hline
ok & ok  \\
\hline
\end{tabular}
\end{center}
\label{default}
\end{table}%
\end{document}
gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2703
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: Barre verticale manquante sur mes tableaux

Message non lu par gigiair »

Il est difficile de trouver la cause du dysfonctionnement avec aussi peu d'indices. Il n'y a aucune raison dans le code pour laquelle le filet vertical ne s'affiche pas. Je pense que cela vient de l'environnement dans lequel se fait la compilation, ou d'un problème avec le visualiseur.
À ta place j'essayerais d'afficher le document final avec un autre visualiseur pour voir si ça vient de la.
On peut aussi modifier le code pour épaissir le filet central à l'aide de l'extension boldline
Par exemple

Code : Tout sélectionner

\documentclass{article}

\usepackage{boldline}
\begin{document}
%>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
\begin{table}[htp]
\caption{default}
\begin{center}
\begin{tabular}{|cV{3}c|}
\hline
ok & ok  \\
\hline
\end{tabular}
\end{center}
\label{default}
\end{table}%
%<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
\end{document}
boldline-tabular.png
boldline-tabular.png (4.24 Kio) Consulté 165 fois
On peut modifier la largeur du filet cV{3} par exemple cV{10}...
Sinon, on peut éplucher le fichier log pour voir s'il n'y a pas de message pouvant expliquer l'absence du filet.
JJR.
LaTeXien migrateur.