Problème profcollege, beamer et Linux

Tout ce qui concerne le langage TeX/LaTeX et ses variantes. Ce langage est utilisable sur le forum via les balises tex.
[participation réservée aux utilisateurs inscrits]
Règles du forum
Merci de soigner la rédaction de vos messages et de consulter ce sujet avant de poster. Pensez également à utiliser la fonction recherche du forum.
zazou
Utilisateur confirmé
Utilisateur confirmé
Messages : 33
Inscription : mercredi 23 novembre 2022, 10:16
Statut actuel : Enseignant

Re: Problème profcollege, beamer et Linux

Message non lu par zazou »

Red a écrit : vendredi 03 mars 2023, 21:11 Conan a raison : la comparaison des deux listfiles montre que le package colortbl n'est pas chargé dans le cas de zazou (il n'est pas présent dans le listfiles).
Que donne la commande kpsewhere colortbl.sty ?
Les versions de Beamer ne sont pas les mêmes. Quelle méthode d'installation avez vous suivi ?

Code : Tout sélectionner

/usr/share/texlive/texmf-dist/tex/latex/colortbl/colortbl.sty
J'ai trouvé !!!!!

J'ai ajouté la ligne

Code : Tout sélectionner

\usepackage{colortbl}
et désormais ça fonctionne!

J'ai donc ajouté la ligne \RequirePackage{colortbl} au sein du package, et désormais plus de problème!
Je suis vraiment content, non seulement parce que ça fonctionne désormais, mais aussi parce que (grâce à vos indications!) j'ai moi-même trouvé la solution, et j'ai mieux compris comment ça fonctionne!

Un grand merci à tous pour le temps que vous avez consacré pour m'aider!
Red
Utilisateur débutant
Utilisateur débutant
Messages : 4
Inscription : vendredi 03 mars 2023, 21:09
Statut actuel : Enseignant

Re: Problème profcollege, beamer et Linux

Message non lu par Red »

Ce n'est pas normal d'ajouter cela.

Code : Tout sélectionner

\documentclass{article}
\usepackage[table]{xcolor}
\begin{document}
\textcolor{red}{Bonjour}
\end{document}
appelle le package colortbl sans ajout particulier.

Il y a donc un souci...
zazou
Utilisateur confirmé
Utilisateur confirmé
Messages : 33
Inscription : mercredi 23 novembre 2022, 10:16
Statut actuel : Enseignant

Re: Problème profcollege, beamer et Linux

Message non lu par zazou »

Chez moi il ne fonctionnait pas, puis j'ai appelé le package colortbl et désormais il fonctionne.

du coup je suis retourné voir le fichier log de JJR et j'ai vu qu'il avait la version 2.14 de xcolor alors que je n'ai que la 2.13.

Je suis alors allé chercher la 2.14 sur CTAN, et je l'ai installée manuellement, et désormais ça fonctionne.
C'est donc de là que venait l'erreur.

Du coup ça soulève une question importante : comment mettre à jour les packages individuellement ? parce que sauf erreur de ma part, les paquets de packages du genre texlive-latex-recommended ne le sont pas toujours.
Avec Miktex sous windows je sais faire mais là ça me semble plus compliqué...
Red
Utilisateur débutant
Utilisateur débutant
Messages : 4
Inscription : vendredi 03 mars 2023, 21:09
Statut actuel : Enseignant

Re: Problème profcollege, beamer et Linux

Message non lu par Red »

Installer la distribution TeXLive à la main en suivant le tutoriel de Denis Bitouzé.
Faire les mises à jour manuellement.
gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2817
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: Problème profcollege, beamer et Linux

Message non lu par gigiair »

Red a écrit : mardi 07 mars 2023, 21:40 Installer la distribution TeXLive à la main en suivant le tutoriel de Denis Bitouzé.
Faire les mises à jour manuellement.
Ce n'est pas la solution que j'ai adoptée. J'installe toujours Debian testing. Il suffit d'installer la version stable et de changer stable en testing dans le fichier /etc/apt/sources.list.
Après j'installe texlive depuis les dépôts Debian et la mise à jour de texlive se fait en même temps que toutes les autres applications. Normalement la mise à jour de texlive a lieu une semaine ou deux (rarement plus) après la sortie de la dernière version. J'ai tous mes logiciels à jour en même temps. Ça fait une vingtaine d'années que je procède ainsi et je n'ai jamais eu trop de soucis.
La version texlive qui vient avec Ubuntu, c'est celle de Debian stable. Elle est à fuir. Je ne sais pas si Ubuntu propose l'équivalent de testing ou sid, mais visiblement texlive ne passionne pas vraiment les mainteneurs d'Ubuntu.
JJR.
LaTeXien migrateur.
zazou
Utilisateur confirmé
Utilisateur confirmé
Messages : 33
Inscription : mercredi 23 novembre 2022, 10:16
Statut actuel : Enseignant

Re: Problème profcollege, beamer et Linux

Message non lu par zazou »

gigiair a écrit : mardi 07 mars 2023, 22:22
Red a écrit : mardi 07 mars 2023, 21:40 Installer la distribution TeXLive à la main en suivant le tutoriel de Denis Bitouzé.
Faire les mises à jour manuellement.
Ce n'est pas la solution que j'ai adoptée. J'installe toujours Debian testing. Il suffit d'installer la version stable et de changer stable en testing dans le fichier /etc/apt/sources.list.
Après j'installe texlive depuis les dépôts Debian et la mise à jour de texlive se fait en même temps que toutes les autres applications. Normalement la mise à jour de texlive a lieu une semaine ou deux (rarement plus) après la sortie de la dernière version. J'ai tous mes logiciels à jour en même temps. Ça fait une vingtaine d'années que je procède ainsi et je n'ai jamais eu trop de soucis.
La version texlive qui vient avec Ubuntu, c'est celle de Debian stable. Elle est à fuir. Je ne sais pas si Ubuntu propose l'équivalent de testing ou sid, mais visiblement texlive ne passionne pas vraiment les mainteneurs d'Ubuntu.
Cette solution me semble beaucoup mieux me convenir, à ceci près que je suis sur ubuntu. Il y a moyen d'installer le texlive de debian sur un ubuntu ?
gigiair
Utilisateur chevronné
Utilisateur chevronné
Messages : 2817
Inscription : samedi 08 juillet 2006, 20:56
Localisation : Saint Bonnet Elvert

Re: Problème profcollege, beamer et Linux

Message non lu par gigiair »

Ben justement, c'est ce que propose Red et Denis Bitouzé. Installer texlive directement avec l'installateur install-tl. Ce n'est pas l'enfer, on peut lancer l'installation en mode graphique en superutilisateur.. Le point délicat est de rendre exécutable les programmes deTeXLIve. Ça ne se fait pas automatiquement, contrairement à l'installation sous Windows.
On peut procéder ainsi :

Code : Tout sélectionner

wget https://mirror.ctan.org/systems/texlive/tlnet/install-tl.zip
unzip install-tl.zip 
sudo install-tl-20230307/install-tl -gui
Dans la boîte de dialogue qui va s'ouvrir, ne pas lancer l'installation avant d'avoir cliqué sur le bouton « AVANCÉ »

Cocher la ligne « créer les liens symboliques dans les répertoires standard »
Sur la ligne SCHEMA, je ne conseille pas de sélectionner la version complète, elle prend beaucoup de temps de téléchargement et si l'on n'a pas l'intention de taper en coréen en hébreu ou en farsi elle contient beaucoup de packages inutiles.
Je conseille de choisir le schéma Texlive du GUST. Si besoin, on pourra compléter avec tlmgr par la suite.
Ensuite valider et attendre patiemment. Ce n'est pas plus long que l'installation depuis les dépôts.

Il y a d'autres façons de faire si on se sent compétent .
JJR.
LaTeXien migrateur.
zazou
Utilisateur confirmé
Utilisateur confirmé
Messages : 33
Inscription : mercredi 23 novembre 2022, 10:16
Statut actuel : Enseignant

Re: Problème profcollege, beamer et Linux

Message non lu par zazou »

Ah OK, désolé. J'avais mal compris ce que Red entendait par "faire les mises à jour manuellement". Je croyais que c'était réinstaller chaque package manuellement à chaque mise à jour, du coup ça m'intéressait moyennement :D

Merci pour l'info, je regarderai ça quand je serai un peu moins sous l'eau !